关注网钛科技

当前位置:首页 > 教程中心 > 数据库

Mysql version can not be less than 4.1是数据库连不上,账号不对

时间:2017-06-14 16:47:59   作者:网钛CMS   来源:云钛网络   阅读:405   评论:0

PHP程序移站时,若提示Mysql version can not be less than 4.1,

  这个直接翻译过来是:Mysql数据库版本不能低于4.1

  貌似是数据库版本的问题,真是这样的吗?但数据库版本已经是5.5版本了啊,因此不会是数据库版本的问题了。

  经查,竟然:

  是没有修改程序和数据库连接的配置文件,汗,这个竟然忘记了,

  才导致出现了Mysql version can not be less than 4.1。

  于是在网站根目录下或DATA目录中找到数据库配置文件 config.inc.php

  #[数据库参数]

  $dbHost="localhost";

  $dbName="test";

  $dbUser="test";

  $dbPass="123456";

  修改上面三个地方的红色部分,问题得到解决。

  注意:如果web空间的IP和数据库的IP不一致的话,还需要配置localhost为相应的数据IP

  还有一种可能,你的数据库名密码错了~这个貌似最常见


相关评论

顶部

QQ在线咨询 服务时间:9:30 - 24:00

400专线
7x24小时全时响应

4006-XXX-XXX